Boxes through a Tunnel in C – Hacker Rank Solution| HackerRank Programming Solutions | HackerRank C Solutions

Hello Programmers/Coders, Today we are going to share solutions of Programming problems of HackerRank of Programming Language C . At Each Problem with Successful submission with all Test Cases Passed, you will get an score or marks. And after solving maximum problems, you will be getting stars. This will highlight you profile to the recruiters.

In this post, you will find the solution for Boxes through a Tunnel in C-HackerRank Problem. We are providing the correct and tested solutions of coding problems present on HackerRank. If you are not able to solve any problem, then you can take help from our Blog/website.

Use “Ctrl+F” To Find Any Questions Answer. & For Mobile User, You Just Need To Click On Three dots In Your Browser & You Will Get A “Find” Option There. Use These Option to Get Any Random Questions Answer.

C is one of the most widely used Programming Languages. it is basically used to build Operating System. C was developed by Dennis Ritchie in 1972. Below are some examples of C Programming which might you understanding the basics of C Programming.

Objectives

You are transporting some boxes through a tunnel, where each box is a parallelepiped, and is characterized by its length, width and height.The height of the tunnel 41 feet and the width can be assumed to be infinite. A box can be carried through the tunnel only if its height is strictly less than the tunnel’s height. Find the volume of each box that can be successfully transported to the other end of the tunnel. Note: Boxes cannot be rotated. 


Input Format

The first line contains a single integer n, denoting the number of boxes.n lines follow with three integers on each separated by single spaces – lengthiwidthi and heighti which are length, width and height in feet of the i-th box.

Constraints

  • 1<=n<=100
  • 1<=lengthi,heighti,widthi<=100 

Output Format

For every box from the input which has a height lesser than 41 feet, print its volume in a separate line.


Sample Input 0

4
5 5 5
1 2 40
10 5 41
7 2 42

Sample Output 0

125
80

Explanation 0

The first box is really low, only feet tall, so it can pass through the tunnel and its volume is 5 * 5 * 5 = 125The second box is sufficiently low, its volume is 1 * 2 * 40 = 80The third box is exactly 41 feet tall, so it cannot pass. The same can be said about the fourth box.

Boxes through a Tunnel C – Hacker Rank Solution
#include <stdio.h>
#include <stdlib.h>
#define MAX_HEIGHT 41

struct box
{
 /**
 * Define three fields of type int: length, width and height
 */
 int length;
 int width;
 int height;
}b;

typedef struct box box;

int get_volume(box b) {
 /**
 * Return the volume of the box
 */
 return (b.length*b.width*b.height);
}

int is_lower_than_max_height(box b) {
 /**
 * Return 1 if the box's height is lower than MAX_HEIGHT and 0 otherwise
 */
    if(b.height > 40)
 {
  return 0;
 }
 else
 {
  return 1;
 }
}

int main()
{
 int n;
 scanf("%d", &n);
 box *boxes = malloc(n * sizeof(box));
 for (int i = 0; i < n; i++) {
  scanf("%d%d%d", &boxes[i].length, &boxes[i].width, &boxes[i].height);
 }
 for (int i = 0; i < n; i++) {
  if (is_lower_than_max_height(boxes[i])) {
   printf("%d\n", get_volume(boxes[i]));
  }
 }
 return 0;
}

47 thoughts on “Boxes through a Tunnel in C – Hacker Rank Solution| HackerRank Programming Solutions | HackerRank C Solutions”

  1. Nice read, I just passed this onto a colleague who was doing a little research on that. And he actually bought me lunch as I found it for him smile Therefore let me rephrase that: Thank you for lunch!

    Reply
  2. What i don’t understood is actually how you’re now not actually a lot more neatly-favored than you may be now. You’re so intelligent. You recognize thus considerably on the subject of this matter, produced me for my part believe it from so many various angles. Its like women and men aren’t interested until it is one thing to do with Lady gaga! Your personal stuffs nice. Always care for it up!

    Reply
  3. Thanks, I’ve just been searching for information approximately this subject for a long time and yours is the greatest I have came upon so far. But, what in regards to the conclusion? Are you sure about the source?

    Reply
  4. I found your blog website on google and test just a few of your early posts. Proceed to keep up the excellent operate. I just further up your RSS feed to my MSN Information Reader. Searching for forward to studying more from you in a while!…

    Reply
  5. I like what you guys are up too. Such intelligent work and reporting! Keep up the excellent works guys I have incorporated you guys to my blogroll. I think it’ll improve the value of my web site 🙂

    Reply
  6. obviously like your web-site however you have to take a look at the spelling on several of your posts. A number of them are rife with spelling issues and I find it very bothersome to tell the truth then again I will certainly come back again.

    Reply
  7. I truly appreciate this post. I¦ve been looking all over for this! Thank goodness I found it on Bing. You’ve made my day! Thanks again

    Reply
  8. hello there and thanks to your information – I’ve definitely picked up anything new from proper here. I did alternatively expertise several technical issues using this site, since I skilled to reload the site lots of times previous to I could get it to load correctly. I had been pondering if your web hosting is OK? Not that I’m complaining, however slow loading cases occasions will sometimes impact your placement in google and could harm your high-quality ranking if advertising and ***********|advertising|advertising|advertising and *********** with Adwords. Well I am including this RSS to my e-mail and could look out for much more of your respective fascinating content. Make sure you update this again very soon..

    Reply
  9. The next time I learn a blog, I hope that it doesnt disappoint me as much as this one. I imply, I do know it was my choice to learn, however I actually thought youd have one thing fascinating to say. All I hear is a bunch of whining about something that you could repair if you werent too busy searching for attention.

    Reply

Leave a Comment

Ads Blocker Image Powered by Code Help Pro

Ads Blocker Detected!!!

We have detected that you are using extensions to block ads. Please support us by disabling these ads blocker🙏.

Powered By
Best Wordpress Adblock Detecting Plugin | CHP Adblock