Day 26: Nested Logic In Java | 30 Days Of Code | Hackerrank Programming Solutions

Hello Programmers/Coders, Today we are going to share solutions of Programming problems of 30 Days Of Code, HackerRank. At Each Problem with Successful submission with all Test Cases Passed, you will get an score or marks. And after solving maximum problems, you will be getting stars. This will highlight your profile to the recruiters.

In this post, you will find the solution for Day 26: Nested Logic in Java-HackerRank Problem. We are providing the correct and tested solutions of coding problems present on HackerRank. If you are not able to solve any problem, then you can take help from our Blog/website.

Use โ€œCtrl+Fโ€ To Find Any Questions Answer. & For Mobile User, You Just Need To Click On Three dots In Your Browser & You Will Get A โ€œFindโ€ Option There. Use These Option to Get Any Random Questions Answer.

Link for the ProblemDay 26: Nested Logic โ€“ Hacker Rank Solution

Day 26: Nested Logic โ€“ Hacker Rank Solution

Problem:

Objective
Today’s challenge puts your understanding of nested conditional statements to the test. You already have the knowledge to complete this challenge, but check out the Tutorial tab for a video on testing.

Task
Your local library needs your help! Given the expected and actual return dates for a library book, create a program that calculates the fine (if any). The fee structure is as follows:

  1. If the book is returned on or before the expected return date, no fine will be charged (i.e.: .
  2. If the book is returned after the expected return day but still within the same calendar month and year as the expected return date, .
  3. If the book is returned after the expected return month but still within the same calendar year as the expected return date, the .
  4. If the book is returned after the calendar year in which it was expected, there is a fixed fine of .

Example
 returned date
 due date

The book is returned on time, so no fine is applied.

 returned date
 due date

The book is returned in the following year, so the fine is a fixed 10000.

Input Format

The first line contains  space-separated integers denoting the respective , , and  on which the book was actually returned.
The second line contains  space-separated integers denoting the respective , , and  on which the book was expected to be returned (due date).

Constraints

Output Format

Print a single integer denoting the library fine for the book received as input.

Sample Input

STDIN       Function
-----       --------
9 6 2015    day = 9, month = 6, year = 2015 (date returned)
6 6 2015    day = 6, month = 6, year = 2015 (date due)

Sample Output

45

Explanation

Given the following return dates:
Returned: 
Due: 

Because , it is less than a year late.
Because , it is less than a month late.
Because , it was returned late (but still within the same month and year).

Per the library’s fee structure, we know that our fine will be . We then print the result of  as our output.

Day 26: Nested Logic โ€“ Hacker Rank Solution
import java.util.Scanner;

/**
 * @author Techno-RJ
 *
 */
public class Day26NestedLogic {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String actualDate = sc.nextLine();
		String expectedDate = sc.nextLine();
		sc.close();
		int fine = 0;
		String[] dateDetail = actualDate.split(" ");
		String[] eDetail = expectedDate.split(" ");

		int aDate = Integer.parseInt(dateDetail[0]);
		int aMonth = Integer.parseInt(dateDetail[1]);
		int ayear = Integer.parseInt(dateDetail[2]);

		int eDate = Integer.parseInt(eDetail[0]);
		int eMonth = Integer.parseInt(eDetail[1]);
		int eYear = Integer.parseInt(eDetail[2]);

		if (ayear > eYear) {
			fine = 10000;
		} else if (ayear == eYear && aMonth > eMonth) {
			fine = 500 * (aMonth - eMonth);
		} else if (ayear == eYear && aMonth == eMonth && aDate > eDate) {
			fine = 15 * (aDate - eDate);
		}
		System.out.println(fine);
	}

}

26 thoughts on “Day 26: Nested Logic In Java | 30 Days Of Code | Hackerrank Programming Solutions”

Leave a Comment

Ads Blocker Image Powered by Code Help Pro

Ads Blocker Detected!!!

We have detected that you are using extensions to block ads. Please support us by disabling these ads blocker๐Ÿ™.

Powered By
Best Wordpress Adblock Detecting Plugin | CHP Adblock